Seis años con el blog

Ya van seis años con el blog, ¡quién lo diría!. Hasta la fecha, ha sido una aventura a trompicones, pues estuvo varios años funcionando correctamente hasta que por mudanzas, pasé a vivir a un sitio sin posibilidad de contratar Internet. A eso se le suma que cuando por fin hubo conexión, el Servidor decidió morir y estuve muchos meses con el “proyecto recuperación”, el cual nunca llegó a buen puerto… es más, el Servidor sigue en mi habitación parcialmente desmontado.

Tiempo más tarde, con el RapsBerry Pi traté de recuperarlo y, aparentemente, funcionaba, pero se corrompió la tarjeta donde va todo el sistema operativo repetidas veces lo que me hizo abandonar, hasta que le volví a dar vueltas al RaspBerry y, con un disco duro externo, se solventa el problema… así lleva al menos 3 meses: sin ruido, bajo consumo, muy lento sirviendo las páginas pese a la fibra de 100/100 que por fin tengo…

Veamos cuántos años más sigue.

Bajamos de la nube

Pues eso… La nube, estuve mirando precios y se hacía bastante cara, así que, con un RaspberryPi y un adecuado particionado/uso de disco duro externo, creo que podré salir adelante.

Veamos cómo evoluciona y si esta aventura RaspberryPi llega a mejor puerto que la última, donde se me corrompió la SD un par de veces perdiéndose todo.

¿Ataque al server?

Alguno sabéis que, además del dominio, tengo un hosting. En éste tengo ciertas partes de la web publicadas. Pues bien, el otro día, llega un correo del servicio de hosting diciendo que habíamos excecido el límite mensual y que en tres días nos lo cierran.

Entro en el “panel de control” desde el que se gestiona todo y se obtienen estadísticas y veo que lo hemos superado en unas 150 veces… y lo mejor de todo, en un sólo día. Es realmente extraño, así que les indico que, o bien se debe a un fallo suyo o bien un ataque (DoS, DDoS…), pues por mi parte, necesito más de una semana para generar tal volumen de tráfico.Responden diciendo que parece que ha habido algún fallo y lo van a comunicar al Servicio Técnico.

El caso es que, a día de hoy, nos han cerrado el acceso hasta el próximo mes (un par de días quedan) y sigo esperando contestación y los logs del servidor para ver qué ha podido ser.

Renovando los certificados

Pues sí, ya tocaba renovar los certificados del servidor expedidos por CAcert. En su momento, cuando los generé, debido a que mi nivel de confianza no era muy elevado (CAcert se basa en niveles de confianza de los “usuarios”, cuantos más “notarios” dan fé de ti, mayor es tu índice de confianza), los certificados que podía generar eran por muy poco tiempo.

A día de hoy, y gracias a que conozco personalmente a dos “notarios” de CAcert, tengo un mayor nivel de confianza y por tanto, los certificados que obtengo son por dos años.

Bueno, a lo que iba, que he renovado el certificado y ahora son válidos hasta el 2010… a ver si este proyecto de blog sigue adelante y me toca renovarlo de nuevo y, sobre todo, ¡me acuerdo cómo se hace!

Por cierto, os recuerdo que en el panel derecho del blog, bajando un poco tenéis un enlace a CAcert para descargar el certificado raíz y que no os salten excepciones en el navegador, pues a día de hoy, todavía no vienen de serie con Firefox.

Disaster recovered: los detalles

Finalmente, ya está el servidor completamente funcional, pues quedó pendiente el audio que no parecía detectar la tarjeta integrada en placa.

Por lo pronto, tengo dos módulos de 512MB RAM DDR2 a 533MHz que regalo a quien los quiera, pues como compré 1GB pensando que de aquí venía el problema, ahora me sobran… (en las nuevas placas, sólo hay dos slots para RAM, no como antes con cuatro).

Ahora, los detalles de cómo ocurrió todo:

Al levantarme por la mañana, observo que el PC está tostado, el Pertellian no se mueve y ha quedado con la última hora en la que el PC funcionó: las 00:36. Otras veces, imagino que debido a la tarjeta de vídeo, el PC se tuesta, así que, apliqué la “típica receta”: botonazo.

Al levantarse el PC, justo cuando tras el grub carga el kernel, comienzan a salir líneas con errores, aunque intercaladas con el resto de líneas:

ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen

Dejé que terminase de arrancar (tras casi 15 minutos) y lo volví apagar de forma ordenada. Esa misma tarde, con una live CD pasé un memtest86, saliendo esto:

Errores en la RAM

Errores en la RAM

Hasta el fin de semana, no pude acercarme a por unas pastillas de RAM. Llegado el sábado, salí pitando a por unas, pero como se suele decir, mi gozo en un pozo. Tras ponerlas, todo igual, ¡incluso los errores del MemTest!. Saqué y volví a poner los módulos, pasando ya con éxito la prueba de RAM, pero los errores seguían.

Con una LiveCD de Ubuntu y con todo desconectado de la placa (discos duros, tarjetas…) comprobé que los errores seguían, así que, por ahí debían venir los problemas y no por la RAM. Como el PC no es nuevo, es complicado conseguir una nueva placa base, pero por otro lado, las que hay son muy baratas, así que, encargué una MSI con chipset nvidia…

MSI P6NGM-FIH

MSI P6NGM-FIH

Durante cambio de placa hubo un momento pánico: el disipador de la CPU no enganchaba, sin embargo, al mover la placa antigua, pude ver cómo por debajo tiene un soporte que lo solucionó todo.

Para terminar, no creo que sea necesario contar el final de la historia… el servidor vuelve a la carga.

Más capacidad

Hacía algún tiempo, comenté que había comprado a un compañero de trabajo un disco duro de 500GB.

Mi idea era tenerlo en la caja externa que tengo, pero, el acceso por USB es lento y no le estaba sacando rendimiento.

Para solucionarlo, he metido el HD en el servidor, por lo que tengo bastante más capacidad, además de tener dos discos internos (quizás me anime a ponerlo en mirror).

Si alguien ha tratado de acceder, es posible que se haya percatado de la indisponibilidad de la web; nada grave, sólo una pequeña mejora. En breve, a la partición que me queda sin uso (la que ha sido sustituida por el nuevo HD) le daré un buen meneo, con lo que espero mejorar aún más la capacidad del sistema… pero eso más adelante.